aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog197
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright23
-rw-r--r--debian/liblua5.1-openssl.files2
-rw-r--r--debian/liblua5.1-openssl.install2
-rw-r--r--debian/liblua5.2-openssl.files2
-rw-r--r--debian/liblua5.2-openssl.install2
-rwxr-xr-xdebian/rules26
9 files changed, 271 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..0c1f04b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,197 @@
+liblua-openssl (20171028-0) unstable; urgency=low
+
+ * Add win32 support
+ * Fix bug where exp would be NULL in pkey.new()
+
+ -- Daurnimator <quae@daurnimator.com> Sat, 28 Oct 2017 13:19:32 +1100
+
+liblua-openssl (20170903-0) unstable; urgency=low
+
+ * Fix pkey.new failing when generating RSA keys
+ * Fix loading C modules clearing interposed fields
+ * Fix building compat-5.3.o
+
+ -- Daurnimator <quae@daurnimator.com> Sun, 03 Sep 2017 22:39:20 +1000
+
+liblua-openssl (20170901-0) unstable; urgency=low
+
+ * New openssl.ocsp.basic and openssl.ocsp.response modules
+ * Add x509:getOCSP()
+ * Add x509:getSignatureName() (#79)
+ * Add crl:verify(publickey)
+ * Add pkcs12.parse(bag[, passphrase])
+ * Add context:setStore(store) and context:getStore()
+ * Add context:setParam(params) and context:getParam()
+ * Add context:setCurvesList(string [, ...])
+ * Add context:setAlpnSelect(cb)
+ * Add context:setTLSextStatusType(type) and context:getTLSextStatusType()
+ * Add ssl:getVerifyResult() (#75)
+ * Add ssl:setContext(context) (#84)
+ * Add ssl:setVerify([mode][, depth]) and ssl:getVerify() (#84)
+ * Add ssl:setCertificate(crt), ssl:setPrivateKey(key), ssl:setCurvesList(string [, ...]) (#84)
+ * Add ssl:setTLSextStatusType(type) and ssl:getTLSextStatusType()
+ * Add ssl:setTLSextStatusOCSPResp(or) and ssl:getTLSextStatusOCSPResp()
+ * Use lua-compat-5.3 (fixes LuaJIT header file compatibility) (#94)
+ * Add generator field to replace exp when generating a DH key
+ * Move away from interfaces deprecated in OpenSSL 1.1.0
+
+-- Daurnimator <quae@daurnimator.com> Fri, 01 Sep 2017 14:20:00 +1000
+
+liblua-openssl (20161214-0) unstable; urgency=low
+
+ * Refactor of bignum operations, fixes bn:sqr()
+
+ -- William Ahern <william@25thandClement.com>
+
+liblua-openssl (20161209-0) unstable; urgency=low
+
+ * Add ssl:getVerifyResult()
+
+ -- William Ahern <william@25thandClement.com>
+
+liblua-openssl (20161208-0) unstable; urgency=low
+
+ * openssl.x509.store:addDefaults() new function to add the operating system's default ca's to a certificate store.
+ * openssl.x509.store:add() can now take a CRL
+ * openssl.ssl.context:getStore() new function that returns a reference to a context's certificate store
+ * openssl.pkey:encrypt() and openssl.pkey:decrypt()
+ * openssl.ssl.new() to construct an SSL* given a SSL_CTX*
+ * Bindings for X509_VERIFY_PARAM*
+
+ -- William Ahern <william@25thandClement.com>
+
+liblua-openssl (20161101-0) unstable; urgency=low
+
+ * Rename bignum methods tobin, todec, tohex to CamelCase: toDecimal, toDecimal, toHex
+
+ -- William Ahern <william@25thandClement.com>
+
+liblua-openssl (20161029-0) unstable; urgency=low
+
+ * Add lots of bignum methods
+ * Allow hex strings creating bignums
+ * Expose openssl.x509.csr
+ * Use autoguess project to get platform features
+
+ -- William Ahern <william@25thandClement.com>
+
+liblua-openssl (20151221-0) unstable; urgency=low
+
+ * Add :tohex and :todec methods to bignums, and make metamethods
+ accessible directly. (daurnimator)
+ * Add __idiv metamethod for Lua 5.3. (daurnimator)
+
+ -- William Ahern <william@25thandClement.com> Mon, 21 Dec 2015 02:35:12 -0800
+
+liblua-openssl (20151218-0) unstable; urgency=low
+
+ * Add :tobin method to bignums. (daurnimator)
+ * Add :getParameters method to pkeys. (daurnimator)
+ * Fix build when SSLv3 support is not present.
+
+ -- William Ahern <william@25thandClement.com> Fri, 18 Dec 2015 03:09:29 -0800
+
+liblua-openssl (20150727-0) unstable; urgency=low
+
+ * More extension work from Kaarle Ritvanen.
+ * Add DTLS support.
+ * More extension work from kunkku.
+ * Fix bug in ex_newstate which could cause application data attached
+ to OpenSSL objects using OpenSSL's external application data API to be
+ prematurely invalidated as-if the Lua interperter was destroyed.
+
+ -- William Ahern <william@25thandClement.com> Mon, 27 Jul 2015 01:42:46 -0700
+
+liblua-openssl (20150504-0) unstable; urgency=low
+
+ * Use lightuserdata as registry keys. C function hashes aren't stable
+ in LuaJIT.
+ * Add openssl.version as binding for SSLeay_version.
+ * Fix build on OpenBSD 5.6 libressl.
+
+ -- William Ahern <william@25thandClement.com> Mon, 04 May 2015 17:49:08 -0700
+
+liblua-openssl (20150422-0) unstable; urgency=low
+
+ * Add support for ALPN server callback, SSL_CTX_set_alpn_select_cb.
+ * Fix X509_STORE double-free bug on older OpenSSL releases (< 1.0.2)
+ by implementing and using our own X509_STORE_free routine which properly
+ checks reference counts. Workaround adapted from Ruby OpenSSL bindings.
+ * Fix strerror_r usage on glibc.
+
+ -- William Ahern <william@25thandClement.com> Wed, 22 Apr 2015 15:39:14 -0700
+
+liblua-openssl (20150304-0) unstable; urgency=low
+
+ * Merge ALPN support from quae@daurnimator.com.
+
+ -- William Ahern <william@25thandClement.com> Wed, 04 Mar 2015 18:11:13 -0800
+
+liblua-openssl (20150225-0) unstable; urgency=low
+
+ * Add DES module to help implement NTLM authentication protocol.
+
+ -- William Ahern <william@25thandClement.com> Wed, 25 Feb 2015 12:46:41 -0800
+
+liblua-openssl (20141028-0) unstable; urgency=low
+
+ * Add ssl:getVersion and ssl:getClientVersion.
+ * Fix "TLS" and "SSL" method names for context.new. OpenSSL TLSv1_method()
+ literally only speaks 1.0, not 1.0 and above. "TLS" now uses
+ SSLv23_method and disables SSLv2 and SSLv3. "SSL" uses SSLv23_method and
+ disables SSLv2.
+
+ -- William Ahern <william@25thandClement.com> Tue, 28 Oct 2014 21:03:23 -0700
+
+liblua-openssl (20140923-0) unstable; urgency=low
+
+ * Add more CRL support from Kaarle Ritvanen.
+ * Add prelimiary 5.3 support.
+ * Add SSL_CTX and SSL option support.
+ * Add ephemeral key support.
+ * Add Server Name Indication (SNI) support.
+ * Fix issue which prevented loading public and private keys together.
+ * Add bindings to opensslv.h and opensslconf.h.
+
+ -- William Ahern <william@25thandClement.com> Tue, 23 Sep 2014 20:32:32 -0700
+
+liblua-openssl (20140718-0) unstable; urgency=low
+
+ * Add CRL spport from Kaarle Ritvanen.
+ * Add PKCS1 support from Kaarle Ritvanen.
+ * Add AIX platform support.
+ * Add rand.stir.
+
+ -- William Ahern <william@25thandClement.com> Fri, 18 Jul 2014 22:44:31 -0700
+
+liblua-openssl (20140328-0) unstable; urgency=low
+
+ * Add DER input/output formats.
+ * Add GEN_DIRNAME alternative names.
+ * Change the return value of several methods from boolean true
+ to the method object, to allow easy call chaining in Lua.
+ * Fix rand.uniform to use lua_Unsigned when it's a 64-bit type (Lua 5.3).
+ * Rename openssl.pubkey to openssl.pkey.
+
+ -- William Ahern <william@25thandClement.com> Fri, 28 Mar 2014 22:44:31 -0700
+
+liblua-openssl (20140322-0) unstable; urgency=low
+
+ * Add Lua 5.3 support.
+ * Add user guide.
+
+ -- William Ahern <william@25thandClement.com> Sat, 22 Mar 2014 20:23:56 -0800
+
+liblua-openssl (20140131-0) unstable; urgency=low
+
+ * Add multi-threaded re-entrancy protection, including explicitly
+ synchronizing OpenSSL initialization because OpenSSL doesn't appear to
+ use its own locking callbacks from initialization routines.
+
+ -- William Ahern <william@25thandClement.com> Fri, 31 Jan 2014 14:27:30 -0800
+
+liblua-openssl (20131209-1) unstable; urgency=low
+
+ * Initial release after splitting from cqueues project.
+
+ -- William Ahern <william@25thandClement.com> Sun, 09 Dec 2013 21:17:33 -0800
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a17b827
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: liblua-openssl
+Section: unknown
+Priority: extra
+Maintainer: William Ahern <william@25thandClement.com>
+Build-Depends: debhelper (>= 9), m4, dh-lua, libssl-dev
+Standards-Version: 3.9.2
+
+Package: liblua5.1-openssl
+Architecture: any
+Depends: openssl, liblua5.1-0
+Description: Comprehensive OpenSSL bindings.
+
+Package: liblua5.2-openssl
+Architecture: any
+Depends: openssl, liblua5.2-0
+Description: Comprehensive OpenSSL bindings.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d4958f8
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,23 @@
+Author: William Ahern <william@25thandClement.com>
+Download: http://25thandclement.com/~william/projects/luaossl.html
+
+Files: *
+Copyright: © 2012-2013, William Ahern
+License: MIT
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to
+deal in the Software without restriction, including without limitation the
+rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+sell copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+IN THE SOFTWARE.
diff --git a/debian/liblua5.1-openssl.files b/debian/liblua5.1-openssl.files
new file mode 100644
index 0000000..84e8b8f
--- /dev/null
+++ b/debian/liblua5.1-openssl.files
@@ -0,0 +1,2 @@
+usr/lib/lua/5.1/_openssl.so
+usr/share/lua/5.1/openssl*
diff --git a/debian/liblua5.1-openssl.install b/debian/liblua5.1-openssl.install
new file mode 100644
index 0000000..325a01a
--- /dev/null
+++ b/debian/liblua5.1-openssl.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/lua/5.1/_openssl.so usr/lib/lua/5.1
+debian/tmp/usr/share/lua/5.1/openssl* usr/share/lua/5.1
diff --git a/debian/liblua5.2-openssl.files b/debian/liblua5.2-openssl.files
new file mode 100644
index 0000000..e513b8d
--- /dev/null
+++ b/debian/liblua5.2-openssl.files
@@ -0,0 +1,2 @@
+usr/lib/lua/5.2/_openssl.so
+usr/share/lua/5.2/openssl*
diff --git a/debian/liblua5.2-openssl.install b/debian/liblua5.2-openssl.install
new file mode 100644
index 0000000..595dc7f
--- /dev/null
+++ b/debian/liblua5.2-openssl.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/lua/5.2/_openssl.so usr/lib/lua/5.2
+debian/tmp/usr/share/lua/5.2/openssl* usr/share/lua/5.2
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..10c05a8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+CFLAGS := -O3 -g -fstack-protector --param=ssp-buffer-size=4
+
+DESTDIR=debian/tmp
+prefix=/usr
+build=liblua5.1-openssl liblua5.2-openssl
+install=$(addsuffix -install,$(build))
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ true
+
+override_dh_auto_build:
+ make DESTDIR=$(DESTDIR) prefix=$(prefix) $(build)
+
+override_dh_auto_install:
+ make DESTDIR=$(DESTDIR) prefix=$(prefix) $(install)
+
+override_dh_auto_clean:
+ make clean
+
+override_dh_auto_test:
+ true