aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright23
-rw-r--r--debian/liblua5.1-openssl.files2
-rw-r--r--debian/liblua5.1-openssl.install2
-rw-r--r--debian/liblua5.2-openssl.files2
-rw-r--r--debian/liblua5.2-openssl.install2
-rwxr-xr-xdebian/rules26
9 files changed, 79 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..4d5e440
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+liblua-openssl (20131209-1) unstable; urgency=low
+
+ * Initial release after splitting from cqueues project.
+
+ -- William Ahern <william@25thandClement.com> Sun, 09 Dec 2013 21:17:33 -0800
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a17b827
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: liblua-openssl
+Section: unknown
+Priority: extra
+Maintainer: William Ahern <william@25thandClement.com>
+Build-Depends: debhelper (>= 9), m4, dh-lua, libssl-dev
+Standards-Version: 3.9.2
+
+Package: liblua5.1-openssl
+Architecture: any
+Depends: openssl, liblua5.1-0
+Description: Comprehensive OpenSSL bindings.
+
+Package: liblua5.2-openssl
+Architecture: any
+Depends: openssl, liblua5.2-0
+Description: Comprehensive OpenSSL bindings.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d4958f8
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,23 @@
+Author: William Ahern <william@25thandClement.com>
+Download: http://25thandclement.com/~william/projects/luaossl.html
+
+Files: *
+Copyright: © 2012-2013, William Ahern
+License: MIT
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to
+deal in the Software without restriction, including without limitation the
+rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+sell copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+IN THE SOFTWARE.
diff --git a/debian/liblua5.1-openssl.files b/debian/liblua5.1-openssl.files
new file mode 100644
index 0000000..84e8b8f
--- /dev/null
+++ b/debian/liblua5.1-openssl.files
@@ -0,0 +1,2 @@
+usr/lib/lua/5.1/_openssl.so
+usr/share/lua/5.1/openssl*
diff --git a/debian/liblua5.1-openssl.install b/debian/liblua5.1-openssl.install
new file mode 100644
index 0000000..325a01a
--- /dev/null
+++ b/debian/liblua5.1-openssl.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/lua/5.1/_openssl.so usr/lib/lua/5.1
+debian/tmp/usr/share/lua/5.1/openssl* usr/share/lua/5.1
diff --git a/debian/liblua5.2-openssl.files b/debian/liblua5.2-openssl.files
new file mode 100644
index 0000000..e513b8d
--- /dev/null
+++ b/debian/liblua5.2-openssl.files
@@ -0,0 +1,2 @@
+usr/lib/lua/5.2/_openssl.so
+usr/share/lua/5.2/openssl*
diff --git a/debian/liblua5.2-openssl.install b/debian/liblua5.2-openssl.install
new file mode 100644
index 0000000..595dc7f
--- /dev/null
+++ b/debian/liblua5.2-openssl.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/lua/5.2/_openssl.so usr/lib/lua/5.2
+debian/tmp/usr/share/lua/5.2/openssl* usr/share/lua/5.2
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..10c05a8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+CFLAGS := -O3 -g -fstack-protector --param=ssp-buffer-size=4
+
+DESTDIR=debian/tmp
+prefix=/usr
+build=liblua5.1-openssl liblua5.2-openssl
+install=$(addsuffix -install,$(build))
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ true
+
+override_dh_auto_build:
+ make DESTDIR=$(DESTDIR) prefix=$(prefix) $(build)
+
+override_dh_auto_install:
+ make DESTDIR=$(DESTDIR) prefix=$(prefix) $(install)
+
+override_dh_auto_clean:
+ make clean
+
+override_dh_auto_test:
+ true